Problem uploading public key

I have created a public key following the instructions at Application-restricted RESTful APIs - signed JWT authentication - NHS Digital ; I chose to use the external key generator mentioned in the tutorial. (mkjwk)

I copied the public key that was generated on that page to a file and named it according to my KID so the file was named myapplication-dev-1.json; inside the file there is a kid that matches (myapplication-dev-1).

I navigated to my account and selected the application and from the application information page, I selected the edit link next to Public Key URL.

Here, I ignored the URL and selected my public key file and clicked on upload. My file is 1 KB in size.

On clicking upload I then was at this URL:

And the text was: Page Not Found - We’re sorry, we couldn’t find the page you requested.

Any help you can give would be appreciated.

1 Like

It might be worth mentioning that when I login to the portal, it asks me for SAML authentication. I do not have this set up but it seems to let me proceed anyway. Is it because I do not have this set up that I cannot upload the public key file? I am getting a 404 when it tries to upload the file, and when I check to see if the key has actually been registered against the application, it has not.

If I do need SAML access how do I set this up please?

Thank you,

I have now tried generating the key myself using the bash shell, creating a JWKS endpoint and hosting the jwk on azure and inputting that API path (which i have confirmed works) to the form. No matter what I do, the result is a 404

I noticed there is maintenance of onboarding today; is there any change it might fix this?

Looks like the maintenance will be completed by 10:30 PM in UK time. Your issue is that urgent ?
Btw, just out of curiosity, which steps you are talking about?


I am on step 3 - register your public key with us. I have followed the steps exactly and tried to both upload the json file with the key in it (public key) and also i wrote an api to provide the public key on demand in case this was the problem.

In both cases, I hit a 404 error.

It is not that it is so urgent that I need it fixed NOW, but it seems strange that I am (hopefully) following the instructions exactly and instead of the json file being used to create a JWKS endpoint hosted by the NHS, it errors with a 404 - simply because nobody else seems to have reported issues with the process so far in these forums.

There are 2 possible causes:

  1. something broke at the NHS onboarding site (unlikely but possible, which is why I wonder if the maintenance or simply restarting it might fix the problem so will check tomorrow).
  2. i am doing something wrong (this is more likely).

It would be useful if someone else reading these forums who has already had success with registering their public key could test it again, and if it works for them, then I will know it is probably reason #2 !


Hi Dorothy,

Thanks for getting in touch. This is a known issue and we have a fix awaiting release this Thursday 20/04/23. Apologies for the inconvenience you have experienced.

1 Like

Thank you Haroon! I look forward to trying again on Thursday. Is there a list of known issues which I could reference in the future?


Good to know. thanks for pointing out.
No wonder if this is an issue.

Is there the roadmap to implement this or something we can help out if this is a perpetual issue ?

Hi Tomomi, we have a fix awaiting release this Thursday 20/04/23.

Hi Haroon,
Thank you for the information. Will come back and check around then