MESH API (Int Env) Related Issue

Hello Team,

I am prashant Chourasiya from OX-Digital Health. It is a critical problem related to establish connection between mesh integration server to our server via internet.

On 8th March 2023, we have received two mailbox credentials. Mailbox Id : E82613OT001,C84602OT001. then after we have been continuously working for integrating mesh Api inside our portal.

On 20th March 2023, we had generated CSR and sent request for generating TLS Certificate, after two days we received Client Certificate(TLS Certificate).

we had also sent mail for knowing shared secret.

We had created our keystore and PKCS12.BAC file using MESH certificate tool. we had entered password when generating PKCS12.BAC File. We have pasted three certificates inside mesh certificate tool when the time of generating keystore. 1.Our TLS Certificate 2. Sub CA (SHA2 New certificate valid from 19 November 2019) (NHS INT Level1C) 3. Root CA (SHA2 New certificate valid from 19 November 2019) (NHS PTL Root).

We checked this point :

  1. We are using UK Base IP Address for accessing.
  2. We are using dot net framework for accessing MESH API .
  3. We are adding X.509 Certificate with private key and our certificate.

Technical Description :

We are trying to run Handshake(MESH) API. we are followed Message Exchange for Social Care and Health (MESH) API - NHS Digital this document. according to this document we need to add certificate and add header authorization and some more parameters but getting response is : The SSL connection could not be established, see inner exception. and The specified data could not be decrypted.

Can you please look this matter on urgent basis. if possible, can you please set up one meeting with any technical person for understanding our problem.

Prashant Chourasiya

Just out of curiosity, whats the version of dot net framework?

We are using dot net core 6.0

Sorry to hear it. Have you tried it ? looks a similar issue.

Have you tried using your certifcates, private key and the CA list with a basic tool such as curl to confirm it’s a /net problem ?

Example is here and helped us confirm we’d got the first part right : Message Exchange for Social Care and Health (MESH) API - NHS Digital

@supplier , did you get to the bottom of this issue ?