Developer account - My Applications not responding

Hello Team,

Once logged on and navigating to ‘My developer account’…I choose ‘My Applications’

I see a ‘Manage your applications’ button which takes me to ‘My applications and Teams’
At the moment this is empty…

…so I click on ‘New Application’….but nothing happens. I tried this in both Edge and Chrome.

I’m stuck at this point. Please can you assist? Any ideas?

Hi Ayo,

This was a bug introduced with the last update and has since been resolved, please try again.

Thank you for raising and apologies for the inconvenience.


Hi there,

I’m trying to test API integration with our automation processes at NHS D… I’ve been following the documentation at Personal Demographics Service - FHIR API - NHS Digital

and trying to use the sandbox, which I need API keys to do.

I tried creating a Developer account with NHS Digital but the SAML authentication step seems to have an error and I’m stuck. I have registered an account and clicked the link in the email to activate it, so not sure what step I’m missing.

Below screenshots of steps for reference.

How do you suggest I create an account, and in the meantime is there a way to get API keys or test APIs without keys?

The easiest way to access the sandbox is via the “Try this API” feature, which lets you interact with the sandbox using a swagger-like interface. You don’t need API keys to access the sandbox.

Hope that helps!