401 Access denied when calling patient resource

Hi, we are making a call to the patient resource and get a 401 in response.

Patient resource being called is:


The JWT is being successfully created but the call to the FHIR resource is failing. Within the Developers Onboarding console we have the following API enable:

Spine Directory Service (Integration Testing)

What are we missing? This works fine in the sandbox.

Hi there,

To be clear, do you only have Spine Directory Service (Integration Testing) enabled for your app?

You’ll need to be enabled against Personal Demographics Services (Integration Testing) in order to access that API. PDS’s sandbox environment is open access and does not enforce authentication.

Hi, thanks, I’ve tried that too and still receive a 401 when calling the FHIR resource. API access setup as attached.

Could be a few different things going on here - could I possibly have the app ID of your application? I’ll be able to look into things in more detail.

Hi, it’s 6fcfb7e3-a72d-48c3-86f5-522d33472f18

This has been solved. Was an issue with the JWT “Bearer” text.

1 Like

Could you please tell me what the issue was?

Very simply the text “Bearer” adding been suffixed to the access token on the JWT. We didn’t see it in the sandbox as it isn’t checked.